Error when import file of ifc3X2 into blenderbim,Do the shape or filesize have some limits.

the error report:
File “C:\Users\am\Appdata\roaming\Blender Foundation\Blender\2.9.3\scripts\addons\blenderbim\libs\site\packages\”,line 641,in create_shape
RuntimeError:Failed to process representation item.
Still don’t understand the error report,Can somebody please tell me the reason.

It likely means that your file contains invalid geometry. Can you please send your file to for further debugging? If it is private we can also organise a screenshare session. Alternatively if you wish to debug it yourself there is a variety of IFC inspection tools available in the IFC debug panel.

By the way, this is not quite the right place to submit these types of issues. Please submit either to Issues · IfcOpenShell/IfcOpenShell · GitHub or in the future :slight_smile:

Hi,Moult,truly thanks.
Just rookie to the IFC system and the os series for 11 days.Still learning.
I then tried to import the IFC3X2 Model through Freecad.The report tells :first;Can’t compute inventor representation for the shape of curtain wall, second, some geometry has a null shape;last,
“File “C:\Program Files\FreeCAD 0.19\Mod\Arch\”, line 784, in getCurveSet
t1 = el.Trim1[0].wrappedValue
File “C:\Program Files\FreeCAD 0.19\bin\lib\site-packages\ifcopenshell\”, line 64, in getattr
raise AttributeError(
<class ‘AttributeError’>: entity instance of type ‘IfcCartesianPoint’ has no attribute ‘wrappedValue’”
But Freecad finished the import work and show me the IFC3X2 model in the screen.
Then export the model into IFC3X2 using Freecad and import the export model into blenderbim.
Finally there is no error report, the tree tab shows the model structural,the import sucess.
Also i tried to import the first IFC3X2 into rhino through VisualARQ 2,there is no error report ,and the geometry matchs the original model maybe most perfect,even shows the invisible Boolean geometry XD。Then do the same freecad things,export and import into blenderbim.Maybe the export model retains too much geometry things of the original model,the same error report like before.
I compare the information of import finished model in the FreeCAD and rhino.Blenderbim and visualARQ retains more information of orginal model.Maybe not retain more,but shows in tab more.Because the Blenderbim import model come from freecad .
My poor english hopes you understand my blabla.I send the the three IFC3X2 model to your email,the orignal model,Freecad export model and rhino export model.

@cabancey thanks for sending your file.

Yes, your file is unfortunately invalid. You have quite a few instances of IfcGridAxis which are missing axis curves.

For example:

#223003= IFCGRIDAXIS('',$,.T.); <-- Invalid, missing Axis Curve

This is causing the import to fail.

In addition, you have also placed a shape representation “contained in” a spatial structure. This is also invalid and will cause imports to fail.

2021-08-11 11:41:42,143    ERROR 159 In #71=IfcRelContainedInSpatialStructure('x_YfrTEQGDMceGyk752d0G',#2,'',$,(#222830,#223049,#231627,#231725,#231824,#282113,#282118,#282248,#282253,#282369,#282374,#282504,#282509,#282625,#282630,#282872,#282877,#282993,#282998,#283170,#283175,#283305,#283310,#283441,#283446),#64)
#282118=IfcShapeRepresentation(#21,'Body','Brep',(#282119)) not valid for <entity IfcProduct>

The BlenderBIM Add-on is relatively strict in requiring valid IFCs. There may be more hidden problems, but these are the easily checkable ones. If your file works in other viewers with no error logs, that might be a cause for concern - maybe you should reach out to them and ask them to include error logs, otherwise this exacerbates the problem of uncertainty with IFC data.

Please reach out to your vendor to fix this in their export. The vendor seems to be “Grandsoft” / “Glodon”.

Hope it helps. Maybe the vendor might want to reach out to buildingSMART too for official support for certification.

@Moult thanks for your work.
Now try to figure out through console report, fix the model.
Finally thanks for your help again.

Hi,@Moult,Can i ask how you find the error in the IFC file?
When i scan the file, don’t know where and how to start.
Do you have some advice or what documentation need to read.

@cabancey there is a “IFC Debug” panel at the bottom of the scene properties. Browse to your IFC file, and click the “validate IFC file” button. That will check for basic validation errors like whether required fields are available. You can see the results in the console. You can toggle the system console using Window->Toggle System Console.